Hyundai Santa Fe Forums banner
1 - 4 of 4 Posts

Registered
Joined
1 Posts
Discussion Starter · #1 ·
I just purchased a 2015 santa fe GLS with the ultimate package. The problem im having is when the SIMM card for the navigation system is installed the blue link will keep trying to load every couple of min. I have reboted the Blue Link with no luck. The radio and satalight are working fine. I took it to the dealer and they reset it also and said that was the most they could do, except replace the entire unit at $$$$$. Any words of wisdom or things to try?

Mark Johnson
 

Registered
Joined
1 Posts
I also have a 2015 GLS Ultimate with the same issue. BlueLink is stuck on the loading screen. Every few days (if I'm lucky) the screen returns to normal. I went to the dealer and they immediately told me that I need to replace the entire radio assembly for a cool $2,000!! My radio, AC unit still work. I obviously can use my navigation or phone, etc. but this is so frustrating.

The dealer tells me that this is an issue that they recently discovered (such a big fat lie!!). He then says they can replace the whole unit but that I would have to contact Hyundai America if I want something else done, because his dealership was "just" a franchise. 馃槨 It seems like some type of software glitch but I guess they get more $$$ this way. Unless they come up with another fix for this issue, I will never buy or recommend another Hyundai.

Anyone have any idea how to fix this??
 

Registered
Joined
3 Posts
It's not necessarily Hyundai issue it's navigation systems issue in vehicles from various manufacturers. I see a few years ago onboard NAV systems pulled Lexus' reliability down, I try and avoid onboard NAV like the Plague. A friend of mine ditched a 2014 Mazda CX-5 he bought brand new with NAV and head unit issues.
 
1 - 4 of 4 Posts
Top