Hyundai Santa Fe Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello all,
Have an odd problem but havent seen the solution anywhere. My car turns on fine, but after a few minutes running, keeps stalling when in idle (stop light or so). There are no warning lights and the pattern seems to be that the AC will stop blowing cold, then I know next time I stop the car at a sign it will stall.

Somtimes I turn the ignition on, but if I put in D or R the car will stall again, as there seems to have no power if I step the gas pedal.

If the car stalls when the revs drop then it will re-start ok, but the throttle again will not respond for about 15 seconds, then all of a sudden it will be ok and I can drive off.

Noticed also that when this misterious malfuction is in place, the car tends to heat. Then the same way the problem occurs, it disappears and the car is fine, AC blowing very cold, running fine.

I read somewhere here to check the ground cable. Could that be anything related?

One thing for sure, parked the car yesterday at a garage and just now the guy called me saying I need to replace the water pump ?!?!?!?!?! I cannot see any relation and I´m picking up the car today since I totally lost confidence on this guy.

Thanks for sharing ideas.

Claudio Prado
Lisbon - Portugal
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #2 ·
Update: I noticed that the collant fluid was low. I filled the reservior and also the radiator directly. Haven´t got the stalling problem for 3 days. AC blowing freezing cold. I cannot find a relation between the two things. Anyone?
 
1 - 2 of 2 Posts
Top